Verbindung zur GlobalProtect-Anwendung im Chromebook nicht möglich, Benutzer erhalten während der Authentifizierung mit dem Portal unter Verwendung von SAML die Meldung „XML-Zugriff verweigert“
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Created On 04/24/23 23:29 PM - Last Modified 01/24/25 22:01 PM
Symptom
- Chromebook versucht, mit GlobalProtect eine Verbindung herzustellen.
- Der Browser zeigt die XML-Meldung „Zugriff verweigert“ an.
<Error>
<Code>AccessDenied</Code>
<Message>Access Denied</Message> <<<<<<<<<
<RequestId>A10WKATFXMGH3MVB</RequestId>
<HostId>S0e8W1iVYEnqrjI0axuqaQz/uEmoYcJ3osu88fp1woQGMZJWyST2J0kEr2M4NwsFun0G5+jm4+8</HostId>
</Error>
Environment
- GlobalProtect App auf dem Chromebook
- SAML-Authentifizierung
Cause
- Das Problem liegt darin, dass die Umleitungs URL die Anwendung nicht aufruft.
- Dies führt dazu, dass der Deep Link im Android-Betriebssystem Status ist.
- Der defekte Link führt dazu, dass beim Versuch der Authentifizierung mit dem Standard(-) ein XML-Fehler angezeigt wird.
Resolution
- Um das Problem zu beheben, ändern Sie im Chromebook die Einstellung in „In GlobalProtect öffnen“, um die Anwendung nach Abschluss der Authentifizierung zu starten.
- Um zu steuern, ob Links innerhalb von GlobalProtect oder in einem neuen Browser Tab in Chrome geöffnet werden, befolgen Sie die folgenden Schritte
- Wählen Sie unten rechts die Uhrzeit aus
- Wählen Sie „Einstellungen“ > „Apps“ und „Apps verwalten“
3. Wählen Sie eine App (GlobalProtect)
4. Wählen Sie unter „Unterstützte Links öffnen“ die Option „In GlobalProtect öffnen“ aus.
Additional Information
- Es scheint ein bekannter Fehler in Chrome 40+ zu sein
https://developer.chrome.com/docs/multidevice/android/intents/
https://bugs.chromium.org/p/chromium/issues/detail?id=484815
https://bugs.chromium.org/p/chromium/issues/detail?id=484815