Von Prisma nach einem agentenlosen Scan zur Azure-Cloud hinzugefügte Ressourcen werden nicht gelöscht

Von Prisma nach einem agentenlosen Scan zur Azure-Cloud hinzugefügte Ressourcen werden nicht gelöscht

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Created On 04/09/23 09:50 AM - Last Modified 02/19/26 21:48 PM


Symptom


  • In Protokollen können wir Fehler wie die folgenden sehen:
Account is missing permissions. target:"<Target_Name>" hub:"" region: <Region_Name>. <ID> is missing permissions: Microsoft.Resources/subscriptions/resourceGroups/write, Microsoft.Network/networkInterfaces/write, Microsoft.Network/networkInterfaces/delete, Microsoft.Network/networkInterfaces/join/action, Microsoft.Network/networkSecurityGroups/write, Microsoft.Network/networkSecurityGroups/delete, Microsoft.Network/networkSecurityGroups/join/action, Microsoft.Network/virtualNetworks/write, Microsoft.Network/virtualNetworks/delete, Microsoft.Network/virtualNetworks/subnets/join/action, Microsoft.Compute/disks/write, Microsoft.Compute/disks/delete, Microsoft.Compute/disks/beginGetAccess/action, Microsoft.Compute/snapshots/write, Microsoft.Compute/snapshots/delete, Microsoft.Compute/virtualMachines/write, Microsoft.Compute/virtualMachines/delete
DEBU  scanner.go:271 Skipping account "Azure CRI" due to missing permissions
DEBU  scanner.go:253 Failed to check account permissions. target:"<Target_Name>" hub:"" region: <Region_Name>. failed to check account permissions in credential "<Name>": googleapi: Error 403: Request had insufficient authentication scopes.





Environment


  • Azurblau
  • ohne Agent Scannen
  • Ressourcen


Cause


  • Es fehlen Berechtigungen, weshalb die VMs nach Abschluss des Scans nicht gelöscht werden.
  • Wahrscheinlich wurde während des Onboardings über CSPM die agentenlose Scan-Option aktiviert.


Resolution


  • Um das agentenlose Prisma zu verwenden, sind zusätzliche Löschberechtigungen erforderlich, die auch in der Onboarding-Vorlage des Prisma-Onboarding-Flows überprüft werden können. Prisma-Cosole – Einstellungen – Cloud-Konten – Bearbeiten: Konto konfigurieren
  • So deaktivieren Sie das agentenlose Scannen: CSPM – Einstellungen – Cloud-Konto


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