Profondeur maximale de file d’attente des analyses de registre à la demande dans Prisma Cloud Compute
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Created On 04/07/23 20:59 PM - Last Modified 02/10/25 21:11 PM
Symptom
Cet article met l’accent sur la possibilité d’une surcharge potentielle de la file d’attente d’analyse du Registre à la demande. Nous ne sommes pas encore sûrs des symptômes exacts puisque nous nous référons à une situation hypothétique.
- Le symptôme potentiel, tel que confirmé par l’équipe backend, est que la console peut manquer de mémoire (OOM)
- Si vous voyez des messages d’erreur / rejets du côté de la console, cela peut signifier que le message n’est pas accepté par le Defender, donc il reste dans la file d’attente de la console
Environment
- Prisma Cloud Compute - Auto-hébergé et SaaS (Toutes versions)
- Registre (GCR, , ECRet plus)
Cause
La file d'attente à la demande ne pose généralement aucun problème en raison de la petite taille de ses demandes, cependant, si elle doit provoquer un problème, cela peut affecter la mémoire virtuelle de la console, ce qui peut entraîner une perte de mémoire de la console (OOM) comme indiqué précédemment.
Resolution
- Si nous lançons un redémarrage de la console, les demandes stockées ou alignées dans la file d'attente seront nettoyées étant donné qu'elles sont stockées dans la mémoire de la console, qui est réinitialisée au redémarrage de la console.
- Nous n’avons pas de limite stricte sur le nombre de demandes d’analyse de registre à la demande qui peuvent être effectuées
Additional Information
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