Profundidad máxima de cola de los análisis del Registro bajo demanda en Prisma Cloud el proceso

Profundidad máxima de cola de los análisis del Registro bajo demanda en Prisma Cloud el proceso

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Created On 04/07/23 20:59 PM - Last Modified 02/10/25 21:11 PM


Symptom


Este artículo hace hincapié en la posibilidad de una posible sobrecarga de la cola de análisis del Registro bajo demanda. Todavía no estamos seguros de los síntomas exactos, ya que nos referimos a una situación hipotética.
  • El síntoma potencial confirmado por el equipo de back-end es que la consola podría quedarse sin memoria (OOM)
  • Si ve mensajes de error / rechazos desde el lado de la consola, eso podría significar que el Defender no acepta el mensaje, por lo que permanece en la cola de la consola


Environment


  • Prisma Cloud Compute - Autohospedado y SaaS (Todas las versiones)
  • Registro (GCR, , ECRy más)


Cause


La cola bajo demanda generalmente no causa problemas debido al pequeño tamaño de sus solicitudes, sin embargo, si va a causar algún problema, eso podría afectar la memoria virtual de la consola, lo que podría hacer que la consola se quede sin memoria (OOM) como se discutió anteriormente.

Resolution


  • Si iniciamos un reinicio de la consola, las solicitudes almacenadas o alineadas en la cola se limpiarán dado que se almacenan en la memoria de la consola, que se restablece al reiniciar la consola
  • No tenemos un límite estricto en el número de solicitudes de análisis del Registro bajo demanda que se pueden realizar


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