Prisma Compute : Defender logs show error - Failed to acquire Defender FQDN

Prisma Compute : Defender logs show error - Failed to acquire Defender FQDN

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Created On 04/07/23 08:15 AM - Last Modified 02/10/25 21:11 PM


Symptom


  • Defender log error
ERRO 2023-04-07T07:58:07.453 defender.go:241 Failed to acquire Defender FQDN: /go/src/twistlock/pkg/shared/utils.go:2667 lookup node2-1 on 10.96.0.10:53: no such host

 


Environment


  • Prisma Cloud Compute Edition (Self-Hosted)
  • Prisma Cloud Enterprise Edition (SaaS)
  • Defender logs


Cause


1. The error indicates that the hostname of the host on which the defender is being installed is not resolvable.
2. For example, if the hostname of the worker node is node2-1, but there is not an entry in /etc/hosts then the set of errors below will come up on the defender logs.
DEBU 2023-04-07T07:58:07.164 defender.go:248 Using defender hostname node2-1
ERRO 2023-04-07T07:58:07.453 defender.go:241 Failed to acquire Defender FQDN: /go/src/twistlock/pkg/shared/utils.go:2667 lookup node2-1 on 10.96.0.10:53: no such host

 


Resolution


1. The error is benign (Harmless).
2. There will be no impact on installation or operations of the defender due to this error.
3. However, if a fix is needed, then the hostname should be made resolvable. 
For example in an Ubuntu Worker Node,
If node2-1 is the hostname, then add an entry for it under /etc/hosts for the hostname.
user1@node2-1:~$ sudo nano /etc/hosts

127.0.0.1 node2-1


4. Re-deploy the Defender and then the error should not come up anymore.


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