iOS impossible de se connecter à l’aide de l’authentification GlobalProtect Azure SAML
2664
Created On 02/27/23 16:09 PM - Last Modified 06/07/25 02:58 AM
Symptom
- Configuration de Global Protect avec l’authentification Azure SAML
- Les appareils Windows et Mac OS se connectent correctement
- Les appareils iOS s’authentifient correctement et affichent une page « connexion réussie » mais restent bloqués à « connexion »
- PanGPS.log affiche l’erreur suivante :
Debug(9372): ----Portal Login starts----
Debug(2398): Failed to open file /private/var/mobile/Containers/Shared/AppGroup/8AC5DF39-7F0B-4652-A1FB-848DFE17BB7E/PanPUAC_34684bee1051fea766d2f5f40d5eef7.dat
Debug(9389): Saml auth
Debug(1132): session cleanup.
Debug(8592): Return false for saml/cas auth
Environment
- PA-460
- PanOS 10.2.2-h2
- GlobalProtect Client version 6.0.4-c26
Cause
Dans PanOS 10.1, les SAML résultats de réponse suivants sont manquants dans la réponse, ce qui entraîne l’échec de SAML l’authentification ACS HTTP iOS SAML :
- saml-slo
- nom_utilisateur saml
- prelogin-cookie
- saml-auth-status
Resolution
- Le problème est résolu dans PanOS version 10.2.3 sous PAN-191216
- Effectuez une mise à niveau vers la version préférée pour résoudre le problème.