iOS no se puede conectar mediante la autenticación de GlobalProtect Azure SAML

iOS no se puede conectar mediante la autenticación de GlobalProtect Azure SAML

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Created On 02/27/23 16:09 PM - Last Modified 06/07/25 02:58 AM


Symptom


  • Configuración de Global Protect con autenticación de Azure SAML
  • Los dispositivos Windows y Mac OS se conectan correctamente
  • Los dispositivos iOS se autentican correctamente y muestran una página de "inicio de sesión exitoso", pero se atascan al "conectarse"
Dispositivo iOS atascado al conectarse
  • PanGPS.log muestra el siguiente error:
Debug(9372): ----Portal Login starts----
Debug(2398): Failed to open file /private/var/mobile/Containers/Shared/AppGroup/8AC5DF39-7F0B-4652-A1FB-848DFE17BB7E/PanPUAC_34684bee1051fea766d2f5f40d5eef7.dat
Debug(9389): Saml auth
Debug(1132): session cleanup.
Debug(8592): Return false for saml/cas auth

 


Environment


  • PA-460
  • PanOS 10.2.2-h2
  • GlobalProtect Versión del cliente 6.0.4-c26


Cause


En PanOS 10.1, faltan los SAML siguientes SAML resultados de respuesta en la respuesta, lo que provoca un error en la ACS HTTP autenticación de iOS SAML :
  1. SAML-SLO
  2. saml-nombre de usuario
  3. prelogin-cookie
  4. saml-auth-status


Resolution


  1. El problema se corrigió en la versión 10.2.3 de PanOS en PAN-191216
  2. Actualice a la versión preferida para solucionar el problema.


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