iOS unable to connect to GlobalProtect using Azure SAML authentication
3407
Created On 02/27/23 16:09 PM - Last Modified 06/07/25 02:58 AM
Symptom
- Global Protect setup with Azure SAML authentication
- Windows and Mac OS devices connect successfully
- iOS devices authenticate correctly and display a "login successful" page but get stuck at "connecting"
- PanGPS.log shows the following error:
Debug(9372): ----Portal Login starts----
Debug(2398): Failed to open file /private/var/mobile/Containers/Shared/AppGroup/8AC5DF39-7F0B-4652-A1FB-848DFE17BB7E/PanPUAC_34684bee1051fea766d2f5f40d5eef7.dat
Debug(9389): Saml auth
Debug(1132): session cleanup.
Debug(8592): Return false for saml/cas auth
Environment
- PA-460
- PanOS 10.2.2-h2
- GlobalProtect Client version 6.0.4-c26
Cause
In PanOS 10.1 the SAML following SAML response results are missing in the ACS HTTP response causing iOS SAML authentication to fail:
- saml-slo
- saml-username
- prelogin-cookie
- saml-auth-status
Resolution
- The issue is Fixed in PanOS version 10.2.3 under PAN-191216
- Upgrade to the Preferred release to fix the issue.