The firewall is showing software warranty license expired and not able to upgrade from Panorama but have valid support license

The firewall is showing software warranty license expired and not able to upgrade from Panorama but have valid support license

5100
Created On 02/26/23 19:56 PM - Last Modified 04/07/25 20:35 PM


Symptom


  • The firewalls display license as "support expired" on Panorama and will not be able to upgrade from Panorama.
  • Checking the license on the firewalls confirm the firewalls having a valid support license locally. 
  • Trying to push the PAN-OS software under device deployment on Panorama, the firewalls are not be listed/visible to do a selected push.


Environment


  • Panorama managed Firewalls
  • Supported PAN-OS
  • License


Cause


Expired software warranty license is kept on the firewall. 



Resolution


  1. On the Firewall, delete the expired software warranty license key from the firewall CLI.

> delete license key Software_Warranty<expiredate>.key (check the key-name on the firewall)

  1. Navigate to the firewall GUI to make sure, the expired/deleted key is removed.
  2. Navigate to the Panorama, Panorama > Device Deployment > Licenses > Refresh.
  3. After refresh, the the support license is updated with the valid key and its expiry date.
  4. Retry commit/push from Panorama, it should work fine.
     


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    https://knowledgebase.paloaltonetworks.com/KCSArticleDetail?id=kA14u000000kH6OCAU&lang=en_US&refURL=http%3A%2F%2Fknowledgebase.paloaltonetworks.com%2FKCSArticleDetail&refURL=http%3A%2F%2Fknowledgebase.paloaltonetworks.com%2FKCSArticleDetail