The firewall is showing software warranty license expired and not able to upgrade from Panorama but have valid support license
5100
Created On 02/26/23 19:56 PM - Last Modified 04/07/25 20:35 PM
Symptom
- The firewalls display license as "support expired" on Panorama and will not be able to upgrade from Panorama.
- Checking the license on the firewalls confirm the firewalls having a valid support license locally.
- Trying to push the PAN-OS software under device deployment on Panorama, the firewalls are not be listed/visible to do a selected push.
Environment
- Panorama managed Firewalls
- Supported PAN-OS
- License
Cause
Expired software warranty license is kept on the firewall.
Resolution
- On the Firewall, delete the expired software warranty license key from the firewall CLI.
> delete license key Software_Warranty<expiredate>.key (check the key-name on the firewall)
- Navigate to the firewall GUI to make sure, the expired/deleted key is removed.
- Navigate to the Panorama, Panorama > Device Deployment > Licenses > Refresh.
- After refresh, the the support license is updated with the valid key and its expiry date.
- Retry commit/push from Panorama, it should work fine.