RMA Wizard "replace the device" fails with error: "Authentication secret cannot be null for authentication type psk"

RMA Wizard "replace the device" fails with error: "Authentication secret cannot be null for authentication type psk"

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Created On 02/07/23 01:23 AM - Last Modified 05/31/25 03:31 AM


Symptom


  • RMA Wizard "Replace the device" fails to copy standard VPN Interface
  • The error message: "Authentication secret cannot be null for authentication type psk" is displayed
  • This is seen if authentication override is configured to replacement device and can be verified in the the json config showing psk/cert as null during "replace the device" RMA Wizard.


Environment


  • Prisma SD-WAN
  • Version 6.1
  • IPSec Authentication Override
  • RMA Wizard
  • Ion Devices


Cause


This is done to prevent sensitive information displayed from json config file.

Resolution


  1. Remove the authentication override configuration. An example of how to remove the override is found here
  2. Complete the RMA wizard process. This should complete without error.
  3. Manually configure the authentication information again.


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    https://knowledgebase.paloaltonetworks.com/KCSArticleDetail?id=kA14u000000kGqBCAU&lang=en_US&refURL=http%3A%2F%2Fknowledgebase.paloaltonetworks.com%2FKCSArticleDetail

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