RMA Wizard "replace the device" fails with error: "Authentication secret cannot be null for authentication type psk"
1490
Created On 02/07/23 01:23 AM - Last Modified 05/31/25 03:31 AM
Symptom
- RMA Wizard "Replace the device" fails to copy standard VPN Interface
- The error message: "Authentication secret cannot be null for authentication type psk" is displayed
- This is seen if authentication override is configured to replacement device and can be verified in the the json config showing psk/cert as null during "replace the device" RMA Wizard.
Environment
- Prisma SD-WAN
- Version 6.1
- IPSec Authentication Override
- RMA Wizard
- Ion Devices
Cause
This is done to prevent sensitive information displayed from json config file.
Resolution
- Remove the authentication override configuration. An example of how to remove the override is found here
- Complete the RMA wizard process. This should complete without error.
- Manually configure the authentication information again.