SaaS Security API portal “Request Snippet” section not showing required tabs

SaaS Security API portal “Request Snippet” section not showing required tabs

228
Created On 01/27/23 03:18 AM - Last Modified 09/20/25 03:06 AM


Symptom


One or more user-experience or issue may occur. Some of them

  • Affects legacy tenants where the asset page missing confidence levels(Hi Lo Med) and “Request Snippets” tab
  • Variation of issues with DLP. For example, predefined data patterns and web UI won’t render the page layout
  • Integrated document page of each predefined patterns appear to be editable fields. 
  • Some pages and tabs of the SaaS Security API portal may render misaligned and unformatted page 
  • Missing SaaS Security API App or tenant information in “apps.paloaltonetworks.com

This picture illustrates the “issue” on EXPLORE->Assets->”Specific Asset”
image.png

Working scenario where the snippet section of an asset page show all required tabs:
image.png

Due to this issue, "Request Snippets" tab may be missing. There are documented scenarios where "Request Snippets" tab may not be displayed. 



 


Environment


Legacy(old) SaaS Security API instance which is integrated with the newest cloud services like DLP and snippet infrastructure. 



Cause


This issue occurs due to the “provisioning state of the instance and incompatibility with the integrated cloud services” and HUB workspace  (“apps.paloaltonetworks.com") More accurately the evolutionary software changes of “Request Snippets” and DLP cloud service are not compatible with legacy SaaS Security API instances.



Resolution


Palo Alto Networks provides documented explanation on some of the overlapped user experience. This type of issues need to be investigated and fixed by Palo Alto Networks team.

  • Prior to the support case, ensure that the CSP (support portal) showing valid entitlement. If the tenant instance was created/updated a long time ago, open a ticket and work Palo Alto tech support with some data points         
    • A detailed navigation of the issue with some pictures of snippet section of Explore->Assets->assetA few Asset IDs and policy
    • This type of issues and resolution, may be reviewed by "Palo Alto accounts team " towards "migration or legacy instances to be compliant with other cloud services and apps


Actions
  • Print
  • Copy Link

    https://knowledgebase.paloaltonetworks.com/KCSArticleDetail?id=kA14u000000kGb6CAE&lang=en_US&refURL=http%3A%2F%2Fknowledgebase.paloaltonetworks.com%2FKCSArticleDetail&refURL=http%3A%2F%2Fknowledgebase.paloaltonetworks.com%2FKCSArticleDetail