Error message "Error: 409-UserAlreadyExists, User ‘prisma-cloud-user’ already exists" seen in OCI environment for Prisma Cloud

Error message "Error: 409-UserAlreadyExists, User ‘prisma-cloud-user’ already exists" seen in OCI environment for Prisma Cloud

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Created On 01/22/23 05:37 AM - Last Modified 07/28/23 05:48 AM


Symptom


  • Error message 'Error: 409-UserAlreadyExists, User ‘prisma-cloud-user’ already exists' seen in OCI environment for Prisma Cloud.
oci_identity_user.user: Still creating... [2m0s elapsed]
Error: 409-UserAlreadyExists, User ‘prisma-cloud-user’ already exists
  • In Prisma Cloud, you may also see the message 'OCI users API keys have aged more than 90 days without being rotated' in the Alert Overview Page.


Environment


  • Prisma Cloud 
  • Oracle Cloud Infrastructure (OCI)


Cause


  • This Error is owing to previously created User, Group or policy for OCI environment in Prisma Cloud.
  • The User Name, Group Name, and Policy Name must be unique and should not be present in your OCI tenant.


Resolution


  • It is recommended to create a new User, Group, and Policy as listed in Step 3 here :  Add Your OCI Tenant to Prisma Cloud .
  • With this, you can leverage the Terraform template to generate a new user Oracle Cloud Identifier (OCID).


Additional Information


Onboard Your Oracle Cloud Infrastructure Account

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