Panorama는 Strata Logging Service(SLS) 또는 Cortex Data Lake(CDL)에서 로그를 가져올 수 없습니다.
10551
Created On 01/10/23 02:03 AM - Last Modified 06/02/25 08:18 AM
Symptom
- /var/log/pan/logging-services-jobs.log에 오류가 있습니다.
Error String : No matching results found! Empty hits array in Response
- /var/log/pan/reportd.log에 오류가 있습니다.
process_json_query_result: Cloud resp return empty hits array, no matching data found !!
Environment
- 팔로 알토 방화벽
- 프리즈마 액세스 방화벽
- 파노라마
- 클라우드 서비스 플러그인
- Strata 로깅 서비스
Cause
Panorama에 로그가 나타나지 않는 데에는 여러 가지 이유가 있습니다.
- 방화벽에서 중복 로깅이 활성화되어 있으며 방화벽은 로그를 클라우드와 로그 수집기로 전달합니다.
- 일부 멀티 테넌트 환경에서는 파노라마의 일련 번호와 SLS 인스턴스의 매핑이 잘못될 수 있습니다.
- Panorama가 고가용성으로 배포되고 두 Panorama 장치 모두 SLS 인벤토리에 추가되지 않은 경우.
Resolution
- 로그가 실제로 클라우드에 표시되는지 확인하세요.
허브 포털 에 로그인한 다음 SLS 앱 실행합니다.
"탐색" 탭으로 가서 로그가 있는지 확인하세요.
- "로깅 서비스" 라이센스가 유효한지 확인하세요.
Panorama CLI 에서 다음 명령을 실행하세요.
> request license info
- Panorama가 클라우드에 액세스할 수 있도록 포트가 열려 있는지 확인하세요. 활성화 및 온보딩/계획/포트 및 FQDNS를 참조하세요.
- Panorama에 올바른 인증 가 있는지, 클라우드와의 연결이 OK 인지 확인하세요.
Panorama CLI 에서 다음 명령을 실행하세요.
> request plugins cloud_services logging-service status
- 인증 세부정보와 상태 확인하세요.
Panorama CLI 에서 다음 명령을 실행하세요.
> show plugins cloud_services panorama-certificate status
- ( Prisma 전용 ) Panorama가 올바른 테넌트 ID에서 정보를 가져오고 있으며 대응 상태 "성공"인지 확인합니다.
Panorama CLI 에서 다음 명령을 실행하세요.
그런 다음 SLS 웹 대시보드에 로그인 하고 테넌트 ID가 아래 명령에서 반환된 테넌트 ID와 일치하는지 확인합니다.
> debug plugins cloud_services gpcs echo-test
- 방화벽에서 중복 로깅이 활성화되어 있지 않은지 확인하세요.
중복 로깅이 활성화된 경우, SLS의 로그는 Panorama에서 클라우드로 가져오지 않습니다 . Panorama는 중복되지 않은 로그만 쿼리하며, 이 동작은 변경할 수 없습니다.
SELECT * FROM panw.traffic ORDER BY time_generated DESC WHERE ((( is_dup_log is MISSING ) OR ( is_dup_log = 0 )
- SLS 웹 포털 인벤토리 섹션에서 기본 및 보조 파노라마 장치를 포함하여 모든 파노라마 일련 번호가 추가되었는지 확인하세요.
- Panorama의 HA Pair 에 있는 고가용성 구성 에 다른 피어의 일련 번호가 있는지 확인하십시오.
파노라마 > 고가용성 > 설정 > 피어 HA 직렬