Panorama は Strata Logging Service (SLS) または Cortex Data Lake (CDL) からログを取得できません
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Created On 01/10/23 02:03 AM - Last Modified 06/02/25 08:18 AM
Symptom
- /var/log/pan/logging-services-jobs.log にエラーがあります
Error String : No matching results found! Empty hits array in Response
- /var/log/pan/reportd.log にエラーがあります
process_json_query_result: Cloud resp return empty hits array, no matching data found !!
Environment
- パロアルトファイアウォール
- Prisma Access ファイアウォール
- パノラマ
- クラウドサービスプラグイン
- 地層ログサービス
Cause
ログが Panorama に表示されない理由は複数あります。
- ファイアウォールで重複ログが有効になっており、ファイアウォールはログをクラウドとログ コレクターに転送しています。
- 一部のマルチテナント環境では、Panorama のシリアル番号と SLS インスタンスのマッピングが正しくない場合があります。
- Panorama が高可用性で展開されており、両方の Panorama デバイスが SLS インベントリに追加されていない場合。
Resolution
- ログがクラウド上で実際に表示されていることを確認する
ハブポータルにログインし、SLSアプリケーションを起動します。
「探索」タブに移動し、ログが存在することを確認します。
- 「ログ サービス」ライセンスが有効であることを確認します。
Panorama CLIで次のコマンドを実行します
> request license info
- Panorama がクラウドにアクセスできるように、ポートが開いていることを確認してください。 「Activation-and-onboarding/planning/ports-and-fqdns」を参照してください。
- Panorama に正しい証明書があり、クラウドとの接続がOkであることを確認します。
Panorama CLIで次のコマンドを実行します
> request plugins cloud_services logging-service status
- 証明書の詳細とステータスを確認します。
Panorama CLIで次のコマンドを実行します
> show plugins cloud_services panorama-certificate status
- ( Prisma のみ) Panorama が正しいテナント ID から情報を取得していること、および応答ステータスが「成功」であることを確認します。
Panorama CLIで次のコマンドを実行します
次に、SLS Webダッシュボードにログイン、テナントIDが以下のコマンドで返されたテナントIDと一致していることを確認します。
> debug plugins cloud_services gpcs echo-test
- ファイアウォールで重複ログが有効になっていないことを確認します。
重複ログが有効になっている場合、SLS 内のログは Panorama によってクラウドから取得されません。Panorama は重複していないログのみをクエリするため、この動作を変更することはできません。
SELECT * FROM panw.traffic ORDER BY time_generated DESC WHERE ((( is_dup_log is MISSING ) OR ( is_dup_log = 0 )
- SLS Webポータルのインベントリ セクションで、プライマリおよびセカンダリ Panorama デバイスを含むすべての Panorama シリアル番号が追加されていることを確認します。
- PanoramaのHAペアの高可用性設定に、他のピアのシリアル番号が設定されていることを確認します。
Panorama > 高可用性 > セットアップ > ピアHAシリアル