CLD_5001: Failed to associate the device with Cortex Data Lake
656
Created On 12/31/22 06:50 AM - Last Modified 10/16/25 02:01 AM
Symptom
- Trying to Onboard Firewall to a cortex data lake instance.
- The Firewall being onboarded belongs to a different Customer support Portal.
- Customer has multiple CSP accounts and multiple Cortex Data Lake Instances.
- The onboarding of firewall to Cortex Data Lake fails.
Environment
- Palo Alto Hardware firewalls
- Supported PAN-OS
- Cortex Data Lake (CDL)
- Customer Support Portal (CSP)
Cause
This is caused because on the CDL backend there is a mapping created by Cortex data lake for the firewall serial number.
Resolution
- Contact Support to remove the old mapping on the CDL.
- Support team will internally work with the backend team to remove the mapping.
- Once done, the Firewall can be onboarded to the new CDL Tenant.
Additional Information
- One can move firewalls between CDL tenants in the same CSP account.
- In case when CDL tenants are part of different Customer Support Portal accounts (CSP), One will not see the firewall in the list of firewalls that can be moved.