Web Server and l3svc process exited
8526
Created On 12/30/22 18:07 PM - Last Modified 04/15/25 21:35 PM
Symptom
- GUI is not accessible however CLI is working just fine.
- Upon checking the output of show system software status, we can see the below:
103836.747: admin@TOK-NFW-04(passive)> show system software status
103837.589: Slot 1, Role mp
103837.589: ----------------------------------------
103837.589:
103837.589: Type Name State Info
103837.589: Group all running
103837.591: Process ikemgr running (pid: 4546)
103837.591: Process keymgr running (pid: 4550)
103837.592: Process l2ctrl running (pid: 4553)
103837.592: Process l3svc scheduling (pid: -1) - Requires websrvr running<<<<<<<<<<<<<<
103837.592: Process logrcvr running (pid: 4548)
103839.165: Process useridd running (pid: 4466)
103839.165: Process varrcvr running (pid: 4552)
103839.165: Process web_backend running (pid: 4541)
103839.165: Process websrvr stopped (pid: -1) - Exit Code: 1<<<<<<<<<<<<<<<<<<
Environment
- Palo Alto Firewalls or Panorama
- Supported PAN-OS
Cause
This generally happens due to missing ca.crt file when the certificate was imported and used for the management interface.
Resolution
- To resolve the issue, generate a new cert using CLI using the commands listed below. Replace the certificate parameters to suit your network.
Firewall> request certificate generate ca yes ip <IP Address> hostname <IP Address> days-till-expiry 7300 filename test algorithm RSA rsa-nbits 1024 certificate-name test name <IP Address>
Firewall>configure
Firewall# set shared ssl-tls-service-profile test certificate <name> protocol-settings min-version tls1-0 max-version tls1-2
Firewall# set deviceconfig system ssl-tls-service-profile <name>
Firewall# commit force
Firewall# exit
- After this GUI will load correctly and the status of the processes are displayed correctly.