GlobalProtect connection is disconnected due to 'Received logout command from gateway'
4530
Created On 12/14/22 01:28 AM - Last Modified 08/23/24 02:54 AM
Symptom
- GlobalProtect connection between the GP app and the gateway is disconnected intermittently or at a certain time.
- The following log can be seen in PanGPS.log at the time of the issue.
P15656-T41487 11/16/2022 12:06:55:947 Debug(1466): Received logout command from gatewayEnvironment
- Prisma Access for Mobile Users
- Auto-scaling
- GlobalProtect (GP) App
Cause
- As auto-scale (scale-in) takes place, the existing mobile user connections are disconnected from the gateway and are automatically distributed to the new cloud instances.
- With Auto scaling functionality, When the user load is more than the capacity, the Prisma Access scales out (adds more resources) to support extra Load.
- When the user load is less for certain time, the Prisma Access would scale in as well. (Letting go of the extra resources created earlier).
- As (scale-in) takes place, the existing mobile user connections are disconnected from the gateway and are automatically distributed to the existing cloud instances.
Resolution
- Verify if "resource based auto-scaling" or "scheduled based auto-scaling" is enabled for the tenant.
- If the issue tends to happen at times that match the schedule scaling times, it's likely working as expected.
- Open a support case if the issue does not match the scheduled scaling times.