Device Telemetry "Failed to connect to storage.googleapis.com port 443: No route to host"

Device Telemetry "Failed to connect to storage.googleapis.com port 443: No route to host"

7311
Created On 12/01/22 16:04 PM - Last Modified 02/27/24 03:13 AM


Symptom


  • Show device-telemetry stats all display failure
> show device-telemetry stats all
Device Telemetry Statistics:
device-health-performance:
last-attempt: Wed Nov 03 10:41:40 EST 2022
last-success: N/A
num-of-failed-attempts: 2816
reason: Send File to CDL Receiver Failed
status: failed
.......
  • System logs display "Failed to send: File.." messages
critical device-  send-fa 0  Failed to send: file 'PA_012345678901_dt_10.1.6-h6_20221103_0730_1-hr-interval_HOUR.tgz'.
  • Device Telemetry log (less mp-log device_telemetry_curl.log) display "No route to host"
2022-11-16 10:41:39,503 dt INFO S2: send_file: RSP ERR CODE: . . .'* Failed to connect to storage.googleapis.com port 443: No route to host\n', '*
 Closing connection 0\n', 'curl: (7) Failed to connect to storage.googleapis.com port 443: No route to host\n']


Environment


  • Palo Alto Firewall
  • PAN-OS 9.x and 10.x
  • Device Telemetry


Cause


  • Device telemetry is currently only supported using management port.
  • Service route option is not supported directly in PAN-OS 9.x and 10.x.


Resolution


  1. Configure management port to have access to internet.
  2. If this is not possible configure destination service route using URL.


Actions
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    https://knowledgebase.paloaltonetworks.com/KCSArticleDetail?id=kA14u000000kFQlCAM&refURL=http%3A%2F%2Fknowledgebase.paloaltonetworks.com%2FKCSArticleDetail

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