Prisma Cloud Compute: Hosts not appearing under Compute > Monitor > Vulnerabilities > Hosts when using Non-System Admin Roles
2141
Created On 10/31/22 12:46 PM - Last Modified 12/10/24 14:56 PM
Symptom
- Compute Hosts will not show up in Vulnerability Explorer when using Non-System Admin Roles
Environment
- Prisma Cloud Compute
- Roles
- Hosts
Cause
- The issue is caused by a missing Asterisk (*) in the non-Onboarded Resources list found at the bottom of the Account Group menu.
Resolution
- The Non-System Admin Roles such as Read-Only, Account Group Roles etc. are dependent on Account Groups when it comes to retrieving Cloud Account Resources related information.
- So we typical add Cloud Accounts to an Account Group, which we then add to the Role to allow the Users to view a limited amount of Data that is associated with those Cloud Accounts.
- This error occurs when the Account Group associated with the Role, is missing an Asterisk (*) in the non-Onboarded Resources list found at the bottom of the Account Group menu.
Navigate to Settings > Account Groups > Edit Account Group
Additional Information
View our documentation here on creating account groups.