提交失败并出现错误:找不到应用程序“ntp-base”
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Created On 10/30/22 01:44 AM - Last Modified 01/31/23 00:16 AM
Symptom
尝试提交配置时,失败并显示错误:找不到应用程序“ntp-base”
Environment
- 帕洛阿尔托防火墙或 Panorama
- 支持的PAN-OS.
- 内容更新。
Cause
下载但未安装最新的内容版本。 之后,内容预览与依赖参考基于ntp作为内容控制功能的一部分,通过设计自动添加到候选配置中。 然而,基于ntp不知道当前安装的旧内容版本。
Resolution
- 解决方案 1:此问题是由下载最新内容更新后自动添加的候选配置更改引起的。 这可以通过还原配置更改来简单地解决。 从GUI, 选择设备>设置>操作>恢复到运行配置.
- 解决方案 2:下载并安装最新的应用和威胁内容版本
- 从CLI:
> request content upgrade download latest
> request content upgrade install force yes version latest
> configure
# commit force
- 从GUI:
设备>动态更新>(点击立即检查)>点击下载,然后(下载完成后)单击安装
- 解决方案 3:如果无法安装最新的内容版本(自动提交失败)
- 去除那个NTP从安全策略中应用并从中执行承诺力CLI.
-或者-
- 检查是否NTP应用程序被用于任何安全规则 ()。
- 创建自定义应用程序“NTP- base”并添加安全策略以及NTP,执行提交/提交强制。
笔记:对于新设备,请确保设备具有正确的时区设置,并且NTP服务器设置在那里。
Additional Information
如果应用程序和威胁更新时间表(设备>动态更新>日程:旁应用和威胁行)启用操作“只下载",以后可能会导致此问题和类似问题。 因为如果不定期安装最新的内容版本,安装的内容版本会很旧。 如果最新的内容更新引用了旧安装内容版本中未包含的应用程序,则计划的仅下载更新将再次导致类似问题。 以下是建议的练习选项:-
- 选择 ”下载并安装" 在适用时采取行动。
- 选择 ”没有任何" 禁用操作应用程序和威胁更新时间表,并定期手动安装最新的内容更新。
- 如果 ”只下载" 操作已选择,在每次计划的下载后手动安装下载的内容更新。