GlobalProtect App fails to connect with error 'The virtual adapter was not set up correctly due to a delay.'

GlobalProtect App fails to connect with error 'The virtual adapter was not set up correctly due to a delay.'

20393
Created On 10/24/22 01:56 AM - Last Modified 09/20/24 20:47 PM


Symptom


  • GloblProtect App fails to connect with the error 'The virtual adapter was not set up correctly due to a delay.'
  • Checking the PanGPS.log, observed the below errors.
10:08:40:007 local system error, set error as The virtual adapter was not set up correctly due to a delay. GlobalProtect will try again soon. If the issue persists, try restarting your system.
10:08:40:008 local system error 2, need user action or wait 20 seconds to re-do network discovery 

​​​​​​


Environment


  • GlobalProtect App
  • Prisma Access for Mobile Users


Cause


The 'local system error 2' in PanGPS.log indicates the issue is caused by 3rd party app.
 


Resolution


  1. Uninstall the security applications such as Cylance or Trend Micro etc.
  2. Then, Uninstall the GlobalProtect App for Windows. 
  3. Reinstall the GlobalProtect after reboot of System.
Uninstall of GlobalProtect:
A clean re-install of the GlocalProtect client is needed. Steps below
  1. Uninstall GlobalProtect by running the installer or from 'Uninstall or remove apps and program' in Windows
  2. Delete the GlobalProtect installation folder - C:\Program Files\Palo Alto Networks\GlobalProtect
  3. Delete the GlobalProtect cookies folder contents - C:\Users\<username\AppData\Local\Palo Alto Networks\GlobalProtect\
  4. Delete the registry key by following the steps below: 
    • a. Delete the following registry entries
      •  HKEY_CURRENT_USER\SOFTWARE\Palo Alto Networks\GlobalProtect
      • HKEY_LOCAL_MACHINE\SOFTWARE\Palo Alto Networks\GlobalProtect
    • b. Run the following command as an administrator from the windows cmd line:
      • sc delete PanGPS 
    • c. Reboot the PC
  5. After this, Reinstall the Globalprotect application.


Additional Information


To confirm which 3rd party products are installed in the GlobalProtect client, check the following line in PanGpHip.log.
 10:08:03:025 GpGetHipInfo (DETECT_PRODUCTS) output:
{ "result" :
{ "detected_products" : [
...
 "vendor" : 
{ "name" : "Cylance Inc.",
.
.
.

 


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