« Impossible de réinitialiser tous les utilisateurs ID ! » lors de la tentative de réinitialisation du gestionnaire d’ID utilisateur
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Created On 10/21/22 17:18 PM - Last Modified 07/07/25 20:20 PM
Symptom
- Impossible de réinitialiser user-id-manager sur la haute disponibilité activée Firewall lorsque l’état de l’homologue est inconnu
Environment
- PAN-OS
- Réseau de Palo Alto Firewall
- Haute disponibilité
- Gestionnaire_d’identifiant_utilisateur
Cause
- Lorsque Firewall le mode d’activation haute disponibilité est activé, nous devons d’abord réinitialiser le gestionnaire d’ID utilisateur sur l’appareil homologue . Si nous essayons d’abord de réinitialiser sur le périphérique actif, il échouera et générera l’erreur ci-dessous sur useridd.log
2022-10-21 12:43:17.384 -0500 reset the idmgr of peer first 2022-10-21 12:43:17.384 -0500 Error: pan_shmgr_reset_peer(pan_shmgr.c:4574): sysd_modify_obj($(HA-PEER)ha.lib.idmgr.user.impl.usr.base.idmgr-reset) failed: ALIAS_NOT_FOUND(active)> debug user-id reset user-id-manager type all Failed to reset All User ID manager! <<<<<<<<<< (active)>grep pattern 'reset the idmgr of peer first\|pan_shmgr_reset_peer' mp-log useridd.log 2022-10-21 12:43:17.384 -0500 reset the idmgr of peer first 2022-10-21 12:43:17.384 -0500 Error: pan_shmgr_reset_peer(pan_shmgr.c:4574): sysd_modify_obj($(HA-PEER)ha.lib.idmgr.user.impl.usr.base.idmgr-reset) failed: ALIAS_NOT_FOUND
Resolution
- Si le périphérique homologue est inconnu, désactivez la haute disponibilité à partir de WebUI en accédant à Device>High Availibility>General>Set Up et décochez la case « Activer HA » et réinitialisez le gestionnaire d’ID utilisateur comme solution de contournement temporaire
- Affichez le périphérique homologue et réinitialisez d’abord le gestionnaire d’ID utilisateur sur l’appareil passif, puis sur le périphérique actif.