Prisma Cloud: RQL results limited only to 100K
353
Created On 08/28/23 06:54 AM - Last Modified 12/17/25 03:07 AM
Symptom
- The Investigate Page returned incorrect number with cap around 100K. For example:
The total count should be 790K
The RQL only returned 99K
Environment
- Prisma Cloud
- Investigate page
- RQL
Cause
When Prisma Cloud searching with RQL, it automatically applied a cap=100K, to ensure performance.
Resolution
There are 2 ways to address this issue.
- Open a ticket with Support. This limit can be increased from the backend.
- Alternatively, to get correct total number, Write an API: https://pan.dev/prisma-cloud/api/cspm/search-config/ with higher "limit".