GlobalProtect Transparent upgrade fails with error "Uninstallation not allowed, please contact your IT administrator!" when using version 5.2.8.

GlobalProtect Transparent upgrade fails with error "Uninstallation not allowed, please contact your IT administrator!" when using version 5.2.8.

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Created On 07/31/23 16:07 PM - Last Modified 10/10/24 20:36 PM


Symptom


On endpoints running GlobalProtect 5.2.8, Transparent upgrade is failing with the error below:
Uninstallation not allowed, please contact your IT administrator!


Environment


  • GlobalProtect (GP) App 5.2.8
  • Transparent Upgrade


Cause


  • This error is normally seen when the option 'Allow User to Uninstall GlobalProtect App ' under GlobalProtect Portals Agent App Tab is set to disallow and end user attempts to manually uninstall GP App. 
  • Although the setting should not affect transparent upgrade, the issue occurs due to GPC-13093.


Resolution


One of the following options will resolve the issue.
  1. Set Allow User to Uninstall GlobalProtect App to "Allow".
  2. Upgrade GP to 5.2.9. This version fixes GPC-13093.


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    https://knowledgebase.paloaltonetworks.com/KCSArticleDetail?id=kA14u000000g1yjCAA&lang=en_US&refURL=http%3A%2F%2Fknowledgebase.paloaltonetworks.com%2FKCSArticleDetail

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