Le tunnel Global Protect se déconnecte après la fermeture de la connexion RDP

Le tunnel Global Protect se déconnecte après la fermeture de la connexion RDP

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Created On 05/18/23 13:03 PM - Last Modified 06/27/25 19:37 PM


Symptom


  • RDP est établi sur un PC/bureau distant sur lequel GlobalProtect (GP) est activé
  • Le tunnel GP sur le PC distant est déconnecté après la fermeture de la session RDP.


Environment


  • N’importe quelle version de GlobalProtect Windows
  • N’importe quelle version PAN-OS
  • RDP à n'importe quelle adresse IP de PC disponible (y compris la carte virtuelle Global Protect, l'interface Ethernet... )


Cause


  • Après avoir initié la connexion RDP, le compte d’utilisateur du PC distant est verrouillé automatiquement (comportement attendu).
  • La nouvelle session Windows RDP est ouverte et cette connexion devient une session active.
  • Le tunnel Global Protect est renommé d’un utilisateur PC distant en un utilisateur RDP.
  • Après la fermeture de la connexion RDP, la session Windows RDP est fermée.
  • À l’heure actuelle, le compte d’utilisateur du PC distant est toujours verrouillé.
  • Il n’y a pas de connectivité entre PanGPS et PanGPA, de sorte que le renommage du tunnel de l’utilisateur RDP à l’utilisateur du PC distant ne peut pas réussir.
  • Le processus de renommage du tunnel Global Protect échoue, de sorte que le tunnel Global Protect est déconnecté (comportement attendu).
  • Après avoir déverrouillé le compte, PanGPS et PanGPA sont à nouveau connectés et le renommage du tunnel peut être terminé avec succès.


Resolution


  1. Global Protect doit disposer d’une session utilisateur active pour que la connexion persiste.
  2. Définissez le paramètre de l'application GP Portal « Délai de renommage du tunnel de changement d'utilisateur (s) » sur une valeur suffisamment longue pour permettre aux utilisateurs de PC distants de
  • Déverrouillage du compte
  • Authentification réussie
  • Mise en place d’un tunnel Global Protect.
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