"debug software disk-usage cleanup threshold 90" returns "Server Error" on PA-220
34245
Created On 04/04/23 17:27 PM - Last Modified 04/22/24 06:03 AM
Symptom
- Getting "Server error : op command for client dagger timed out as client is not available" when issuing the CLI command "debug software disk-usage cleanup threshold 90" on a PA-220 with high disk-space issue on root partition.
PA-220 > show system disk-space Filesystem Size Used Avail Use% Mounted on /dev/root 3.8G 3.4G 210M 95% / <<<<<<<<<<< none 2.5G 60K 2.5G 1% /dev /dev/mmcblk0p5 12G 5.0G 5.8G 47% /opt/pancfg /dev/mmcblk0p6 3.8G 1012M 2.6G 28% /opt/panrepo tmpfs 2.5G 349M 2.2G 14% /dev/shm cgroup_root 2.5G 0 2.5G 0% /cgroup /dev/mmcblk0p8 4.6G 351M 4.1G 8% /opt/panlogs /dev/loop0 111M 5.6M 100M 6% /opt/panlogs/wildfire/tmpfile tmpfs 12M 40K 12M 1% /opt/pancfg/mgmt/ssl/private
PA-220 > debug software disk-usage cleanup threshold 90 Server error : op command for client dagger timed out as client is not available
Environment
- PA-220
- PAN-OS version 10.1.x < 10.1.9
- PAN-OS version 10.2.x < 10.2.4
Cause
Timing issue: disk space cleaning isn’t fast enough to compress and remove logs on a PA-220.
Resolution
- Start with a higher cleanup threshold example 94 instead of 90 so the cleaning time will be less which will prevent the server timeout error.
> debug software disk-usage cleanup threshold 94
- You can afterwards gradually keep lowering the threshold value to reach 90
> debug software disk-usage cleanup threshold 93 > debug software disk-usage cleanup threshold 92 > debug software disk-usage cleanup threshold 91 > debug software disk-usage cleanup threshold 90
- If your FW is a PA-220 running PAN-OS version 10.1.x but less than 10.1.9 then upgrade your device to 10.1.9-h1 or higher to fix issue mentioned in PAN-193452 regarding firewall reaching the maximum disk usage capacity repeatedly in one day.
If your FW is a PA-220 running PAN-OS version 10.2.x this issue is still under investigation please contact support for more help.
Additional Information
The same problem and fix are applicable if using the command with the deep option:
debug software disk-usage cleanup deep threshold 90where deep means cleanup with deleting backup logfile.
Note: Sometimes even after applying the workaround you will still get the server error when reaching 91 percent threshold in this case you either need to try the manual cleaning of the disk-space by deleting log and core files one by one as described in HIGH DISK SPACE USAGE ON / ROOT PARTITION AND HOW TO CLEAR or you can opt for the upgrade.