Error “Unable to save. Please try again” when super admin tried to add or delete admin accounts in SaaS Security API
Symptom
In SaaS Security API portal, an error Unable to save. Please try again when super admin attempted to create or delete the other admins.
Here is an example where the SETTINGS->Admin Accounts creation and deletion failed to save the contents.
Environment
A cloud managed NextGen-CASB app hosted in HUB2.0 with a TSG (Tenant Service Group). The migration process does keep the existing legacy SaaS Security API cloud service.
Here is the documentation on how admins navigated to SaaS Security API from a cloud managed NextGen-CASB
A reference documentation to add or delete admins: https://docs.paloaltonetworks.com/saas-security/saas-security-admin/saas-security-api/get-started-with-saas-security-api/manage-saas-security-api-administrators/add-saas-security-api-administrators#ide061bb07-c523-455b-9f50-409fd623c371
Cause
This issue may occur due to User Management conflict of two different portals (SaaS Security API and cloud managed NextGen-CASB). The admin addition or deletion was tried on the SaaS Security API portal while the migrated NextGen-CASB DS User management is based on IAM (Identity Access Management) in Common Services.
Resolution
Its recommended that the User Management of add/delete admins be done via IAM (Identity and Management) part of Common Services.
A reference document for IAM in Common Services can be found in https://docs.paloaltonetworks.com/common-services/identity-and-access-access-management/manage-identity-and-access/about-identity-and-access