Telemetry region list dropdown only shows a single option for the region (eg. Americas)
16230
Created On 07/14/23 00:56 AM - Last Modified 04/19/24 09:22 AM
Symptom
All the Telemetry region is not available on GUI to select, only "Americas" is available under Telemetry Regions.
Environment
- PANOS-10.0.8-hx
- PA-VM-300
Cause
This issue may occur because the device's serial number is already associated with a Cortex instance that is in Americas region.
Below is the command to verify:
admin@FW01> request logging-service-forwarding customerinfo show
Ingest endpoint: a2a849abea63.in2-lc-prod-us.gpcloudservice.com
EAL ingest endpoint: 2ab7dc24c079.fei-lc-prod-us.gpcloudservice.com
Query endpoint: 14dec0c7b30a.api2-lc-prod-us.gpcloudservice.com:444
Customer ID: 12345678
Region : americas
Resolution
You may want to modify the telemetry region as 'India' but only see the 'Americas' option. In this case you need to move the device's serial number from the CDL instance in Americas to the CDL instance in India following the guide below:
Start Sending Logs to a New Cortex Data Lake Instance
After doing this, fetch the customer info again from the firewall CLI:
admin@FW01> request logging-service-forwarding customerinfo fetch
The correct region should now be reflected.
admin@FW01> request logging-service-forwarding customerinfo show
Ingest endpoint: a2a849abea63.in2-lc-prod-us.gpcloudservice.com
EAL ingest endpoint: 2ab7dc24c079.fei-lc-prod-us.gpcloudservice.com
Query endpoint: 14dec0c7b30a.api2-lc-prod-us.gpcloudservice.com:444
Customer ID: 12345678
Region : india
You may now configure the correct region in the firewall CLI:
> configure
# set deviceconfig system device-telemetry device-health-performance yes
# set deviceconfig system device-telemetry product-usage yes
# set deviceconfig system device-telemetry threat-prevention yes
# set deviceconfig system device-telemetry region in
# commit