Prisma Cloud: Okta integration status displays "Not Supported" in Integration Settings

Prisma Cloud: Okta integration status displays "Not Supported" in Integration Settings

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Created On 07/13/23 20:52 PM - Last Modified 02/10/25 22:05 PM


Symptom


  1. Okta Integration Status says "not supported" as seen below. 
GUI Path: Settings > Integrations & Notifications
Screenshot 2023-06-29 at 2.15.17 PM.png
 
  1. The test of the integration was successful with a green status. 
GUI Path: Settings > Integrations & Notifications > Edit IntegrationScreenshot 2023-06-29 at 2.16.32 PM.png
  1. When testing the RQL query it does not produce any results in the Investigate Page.
GUI Path: Investigate Page
Screenshot 2023-06-29 at 2.14.56 PM.png


Environment


  • Prisma Cloud
  • Okta Integration


Cause


Prisma Cloud currently only supports Okta configurations where exactly one value was set. 

GUI Path: In Okta Security> Administrators

image (48) (2).png


Resolution


There is currently a workaround:

  • Use the recommended AWS SSO integration instead of Okta

  • Or use an Okta app for each AWS account

 



Additional Information


View our documentation here for the step by step for Okta Integration. 

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