MONITOR>App Scope>Threat Monitor shows "NO DATA TO DISPLAY" and all the graphs are not shown
342
Created On 06/23/23 09:33 AM - Last Modified 11/05/25 22:41 PM
Symptom
After upgrading the PA-Series Next-Generation Firewall from any version of the PAN-OS 9.1 branch to PAN-OS 10.2.2 or eariler, PAN-OS 10.1.6 or earlier, or any version of the PAN-OS 10.0 branch, MONITOR>App Scope>Threat Monitor shows "NO DATA TO DISPLAY" and all the graphs below in the page are not shown even if there are valid Threat Log entries.
- Last 6 hours
- Last 12 hours
- Last 24 hours
- Last 7 days
- Last 30 days
- Last 60 days
- Last 90 days
The PAN-OS 9.1 branch doesn't have this issue and only the PAN-OS 10.2, 10.1, and 10.0 (EoL) branches are affected.
Please refer to the Environment section for more details.
Environment
- PA-Series Next-Generation Firewalls
- PAN-OS 10.2 branch (10.2.2 or eariler)
- PAN-OS 10.1 branch (10.1.6 or earlier)
- PAN-OS 10.0 branch (All versions are affected, but no fix due to EoL)
Cause
The issue is caused due to an internal datatype mismatch and thus no valid workaround is available if you're using any one of the affected PAN-OS versions.
Resolution
The issue has been addressed in PAN-OS 10.2.3 and 10.1.7 through PAN-177482. All the graphs under MONITOR>App Scope>Threat Monitor will appear again just by upgrading the PA-Series Next-Generation Firewall to any one of the fixed PAN-OS versions.
Please note that if there are no valid Threat Log entries on the target PA-Series Next-Generation Firewall, the page shows "NO DATA TO DISPLAY" even after the upgrade, but this is expected (e.g. If the target device only have some valid Threat Log entries generated a few days ago, the Last 6 hours graph should show "NO DATA TO DISPLAY").
Additional Information
PAN-177482