GlobalProtect Clients drop connection with error "send(88) failed: 10022(An invalid argument was supplied.)" in PanGPS logs
5469
Created On 06/13/23 17:02 PM - Last Modified 05/31/24 03:43 AM
Symptom
- Multiple GlobalProtect users connection drops.
- The GlobalProtect log (PanGPS with debug) log shows the following errors:
(P5004-T12368)Error(1868): 05/30/23 10:19:34:932 Send(88) to socket failed
(P5004-T12368)Error(1012): 05/30/23 10:19:34:932 ProcPackets, ProcDriverData() failed
(P5004-T12368)Info (1034): 05/30/23 10:19:34:932 ProcDrv thread dies
(P5004-T12368)Error( 351): 05/30/23 10:19:34:931 send(88) failed: 10022(An invalid argument was supplied.)
(P5004-T14060)Error( 351): 05/30/23 12:31:11:716 send(328) failed: 10022(An invalid argument was supplied.)Environment
- Palo Alto Firewalls
- GlobalProtect (GP) App
- Supported App versions
Cause
The error message " send(88) failed: 10022(An invalid argument was supplied)" usually means that either Windows or a 3rd party software, such as Carbon Black, or other anti-malware/virus, closed the socket.
Resolution
- Determine and troubleshoot the Antivirus/Anti-Malware/Firewall software on the client machine that is causing connection interruptions.
- This can be done by turning off the software one at a time.