Prisma Cloud: One reason why a user might not see any data in Prisma Cloud pulled from an OCI account after onboarding.
Symptom
After doing the onboarding with Oracle Cloud in Prisma Cloud, we might see that the onboarding was correct but do not see any asset's on that account.
Environment
- Prisma Cloud
- Oracle Cloud Infrastructure
Cause
This happens when we don't supply an email address in the downloaded terraform template from Prisma Cloud during the onboarding step Generate User OCID.
GUI Path: Settings > Cloud Account > Add OCI Account
Notice below after extracting the zip file and opening the OCI-terraform.tf file that there is no email present in the terraform at the very top.
Resolution
In order to fix this, we will need to add in the email field and supply any email address , in my case it was the one associated with my OCI account as seen below:
GUI Path: Login to OCI account > Click Profile
Once that is done and the file is saved , you can rezip it and continue the onboarding process as normal.
Additional Information
Onboarding OCI