Problèmes d’appairage BGP avec le moteur de routage avancé dans PAN-OS 10.2 et 11.0

Problèmes d’appairage BGP avec le moteur de routage avancé dans PAN-OS 10.2 et 11.0

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Created On 03/06/24 22:36 PM - Last Modified 05/07/24 13:57 PM


Symptom


Différents symptômes peuvent être observés en raison de ce problème :

  • Après une « force de commit », les homologues BGP subissent un flap (déconnexion et reconnexion temporaires)
  • Après un redémarrage du pare-feu ou une validation de n’importe quel type, les homologues BGP se déconnectent définitivement et restent bloqués dans l’un des états suivants :
    • >show advanced-routing bgp peer status
      Logical Router: ROUTER_NAME
      ==============
      Peer Name:               PEER_NAME
      BGP State:               Idle
      Last Reset:              Waiting for Peer IPv6 LLA, 08:02:39 ago
    • >show advanced-routing bgp peer status
      Logical Router: ROUTER_NAME
      ==============
      Peer Name:               PEER_NAME
      BGP State:               Connect
      Last Reset:              Waiting for peer OPEN, 00:16:46 ago
      
    • >show advanced-routing bgp peer status
      Logical Router: ROUTER_NAME
      ==============
      Peer Name:               PEER_NAME
      BGP State:               Active
      Last Reset:              Waiting for NHT, 00:09:16 ago
  • Si le comportement décrit ci-dessus est causé par ce problème particulier, il doit être résolu en recréant un nouvel homologue BGP à l’aide de l’adresse homologue BGP existante qui ne fonctionne pas : Routage > réseau > routeurs logiques > Groupe homologue BGP > > [Groupe homologue existant] > Ajouter une nouvelle adresse homologue
  • Si le comportement n’est PAS causé par ce problème particulier, le rajout de l’homologue BGP ne corrigera pas le problème.


Environment


  • Pare-feu Palo Alto Networks
  • PAN-OS 10.2 ou 11.0
  • Moteur de routage avancé activé (configuration > gestion de l’appareil > > routage général > avancé)


Cause


Il existe plusieurs problèmes logiciels distincts responsables de ce comportement, tous suivis sous l’ID de problème PAN-182734

Resolution


  • Ces problèmes sont résolus dans PAN-OS 10.2.5+, 11.0.2+ et 11.1.0+
  • Pour contourner ce problème, une fois que le problème est rencontré si l’homologue BGP est bloqué, recréez une nouvelle entrée d’homologue BGP à l’aide de l’adresse d’homologue BGP existante qui ne fonctionne pas : Routage > réseau > routeurs logiques > Groupe homologue BGP > > [Groupe homologue existant] > Ajouter une nouvelle adresse homologue


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