BGP-Peering-Probleme mit der Advanced Routing Engine in PAN-OS 10.2 und 11.0

BGP-Peering-Probleme mit der Advanced Routing Engine in PAN-OS 10.2 und 11.0

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Created On 03/06/24 22:36 PM - Last Modified 05/07/24 13:57 PM


Symptom


Aufgrund dieses Problems können verschiedene Symptome auftreten:

  • Nach einer "Commit-Force" kommt es bei BGP-Peers zu einer Klappe (vorübergehendes Trennen und erneutes Verbinden)
  • Nach einem Neustart der Firewall oder einem Commit jeglicher Art trennen BGP-Peers dauerhaft die Verbindung und bleiben in einem der folgenden Status hängen:
    • >show advanced-routing bgp peer status
      Logical Router: ROUTER_NAME
      ==============
      Peer Name:               PEER_NAME
      BGP State:               Idle
      Last Reset:              Waiting for Peer IPv6 LLA, 08:02:39 ago
    • >show advanced-routing bgp peer status
      Logical Router: ROUTER_NAME
      ==============
      Peer Name:               PEER_NAME
      BGP State:               Connect
      Last Reset:              Waiting for peer OPEN, 00:16:46 ago
      
    • >show advanced-routing bgp peer status
      Logical Router: ROUTER_NAME
      ==============
      Peer Name:               PEER_NAME
      BGP State:               Active
      Last Reset:              Waiting for NHT, 00:09:16 ago
  • Wenn das oben beschriebene Verhalten durch dieses spezielle Problem verursacht wird, sollte es behoben werden, indem ein neuer BGP-Peer mit der vorhandenen, nicht funktionierenden BGP-Peeradresse neu erstellt wird: Network > Routing > Logical Routers > BGP > Peer Group > [Vorhandene Peergruppe] > Neue Peeradresse hinzufügen
  • Wenn das Verhalten NICHT durch dieses spezielle Problem verursacht wird, wird das Problem durch das erneute Hinzufügen des BGP-Peers nicht behoben.


Environment


  • Palo Alto Networks Firewall
  • PAN-OS 10.2 oder 11.0
  • Erweiterte Routing-Engine aktiviert (Geräte->-Setup > -Verwaltung > Allgemein > Erweitertes Routing)


Cause


Es gibt mehrere separate Softwareprobleme, die für dieses Verhalten verantwortlich sind und alle unter der Problem-ID PAN-182734 verfolgt werden

Resolution


  • Diese Probleme wurden in PAN-OS 10.2.5+, 11.0.2+ und 11.1.0+ behoben
  • Um dieses Problem zu umgehen, erstellen Sie nach dem Auftreten des Problems einen neuen BGP-Peereintrag mit der vorhandenen, nicht funktionierenden BGP-Peeradresse: Network > Routing > Logical Routers > BGP > Peer Group > [Vorhandene Peergruppe] > Neue Peeradresse hinzufügen


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