SaaS security is stuck in activation process

SaaS security is stuck in activation process

341
Created On 01/23/24 19:41 PM - Last Modified 10/27/25 17:54 PM


Symptom


  • Provisioning of a tenant in SaaS security.
  • The activation does not complete and is stuck in the process.


Environment


  • Prisma SaaS
  • SaaS Security
  • DLP
  • HUB


Cause


Occasionally a retrigger from Sonic is needed.



Resolution


First check for any provisioning errors (ElasticSearch, Mongo, others), fix them first. before re-triggering the Sonic.

Steps to re-trigger from Sonic:

  1. Log into Sonic, https://sonic.appsvc.pan.local/lookup.
  2. Click Instance Store (left Menu).
  3. Search the tenant with the Tenant ID or TSG.
  4. Click on Aperture or CASB Tenant ID (example https://sonic.appsvc.pan.local/instance-store/1213219522267898624).
  5. Make sure the "provisioning_status" is different from "complete" ("Provisioning" or "Initializing", "Queuing" or others). If is already "complete", there is nothing to do.
  6. Click COB Debugger  (left Menu).
  7. Search the tenant with the Tenant ID or TSG.
  8. Depending on the results, you might have to find the aperture create-instance or CASB create-instance call.
  9. If needed search for the Job ID that contains the aperture create-instance or CASB create-instance call.

  10. Click on the TASK ID of aperture create-instance or CASB create-instance call. 
  11. Click "Trigger".

  12. A popup of Success or Failure will be shown.
  13. To check when retrigger is done, check on SONIC using https://sonic.appsvc.pan.local/instance-store/<tenantID> and check the field "Updated on" on the list. It should have the same timestamp when the retrigger was done.
  14. If is a Succes wait, 5 or 10 minutes and check again the "provisioning_status" from Tenand ID (Step 5). If it changed status to "complete", should be fixed.


Note:

  • Only aperture create-instance or CASB create-instance calls will work to retrigger. Other task types like "poll-instance" or "modify-instance" will not work/do anything.
  • Please, use the retrigger call in a last resort and on the cases previously described. DO NOT use retrigger without debugging the issue and clicking just hoping to solve the issue.


Additional Information


 



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