Error encountered on the Device Security portal when sending an email invitation to the recently added user in the CSP portal

Error encountered on the Device Security portal when sending an email invitation to the recently added user in the CSP portal

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Created On 01/21/24 00:48 AM - Last Modified 06/10/25 22:58 PM


Symptom


The following error is observed when attempting to send an email invitation from the Device Security portal to the recently added user.

"Your invitation could not be sent at this time, please try again later or contact support for assistance"

 


Environment


Device Security portal HUB 1.0
 


Cause


When the user account is already added to the CSP and assigned a role in HUB 1.0 but not HUB 2.0, and it turns out that the role assignment is invalid because the RBAC API is not returning any roles for the newly added user.

Resolution


There is a need to be switched to the HUB 2.0 version.
There is a toggle button on the top of the Hub portal. (near the Hub logo at the top right)
https://docs.paloaltonetworks.com/hub/hub-getting-started
Turn this toggle off.

Hub-2.0.png
Go to Common Services > Identity & Access.
Select IoT on the Left panel
Select the user and assign the role.

Identify-Acccess.png
https://docs.paloaltonetworks.com/common-services/identity-and-access-access-management/get-started/supertask
https://docs.paloaltonetworks.com/common-services/identity-and-access-access-management/manage-identity-and-access/add-users

* After the above steps are implemented, the user should be able to access the Device Security portal, and there is no need to invite the user to the IoT portal again.


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