Logs from Firewall are not forwarded to panorama when Cortex Data Lake is enabled
6969
Created On 01/17/24 13:51 PM - Last Modified 08/20/24 03:46 AM
Symptom
- Firewalls are configured to send logs to Cortex Data Lake (CDL)logging service.
- The logs are not seen on Panorama.
- logrcvr (less mp-log log-receiver.log) logs show continues connection attempts to the Log collectors and CDL.
- CDL log forward was previously used (license expired) or is not used in the customer environment.
Environment
- Panorama managed Firewalls
- PAN-OS 10.0+
- Cortex Data Lake (CDL)
- Log Collector
Cause
- The CDL is enabled on the Firewall while its not being used or license has expired.
- This setting can be verified on the Firewall using one of the following options.
- Check SDB setting using CLI :
show system state | match cfg.lcaas.*
cfg.lcaas-enabled: True
- Check the CDL status using CLI :
> request logging-service-forwarding status
Logging Service Licensed: No
Logging Service forwarding enabled: Yes
Duplicate logging enabled: No
Enhanced application logging enabled: Yes
Resolution
- Disable the CDL if enabled and not in use.
- This can be done using GUI: Device > Setup > Management > Cortex Data Lake and
- uncheck "Enable Logging Service" and check "Enable Duplicate Logging"
- Restart the log-receiver process on Firewall using "debug software restart process log-receiver". This will refresh the connection.
- Check the logging status after a few mins.
Note: If the changes are done on Panorama, select the appropriate template on which the firewall resides.