Prisma Cloud: Receiving error: "Authentication failed. Azure Subscription not found" when subscription is active
3679
Created On 10/30/23 09:03 AM - Last Modified 10/14/24 15:18 PM
Symptom
During Azure onboarding, it is possible for the Cloud Accounts section to show the error:
"Authentication failed. Azure Subscription not found"
GUI Path: Settings -> Cloud Accounts -> Click on the error icon presented
Environment
- Prisma Cloud
- Onboarding
- Azure
- Cloud Accounts
Cause
If there is a valid subscription associated with the account, this error can be caused by Azure not having a role associated with Prisma. This can occur in larger environments that deploy via .json files if the role does not replicate across the subscriptions.
Resolution
Rerunning the .json file directly on the subscription or manually adding a role in Azure can resolve this issue.
See documentation for resolution path: Custom Roles to Authorize Prisma Cloud Access for customers using a .json file and Manually Authorize Prisma Cloud for customers not using a json or Terraform file.
Additional Information
See: Azure Onboarding for more information.