Prisma Cloud: Splunk Integration receiving Broken logs / Incomplete logs

Prisma Cloud: Splunk Integration receiving Broken logs / Incomplete logs

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Created On 09/20/23 15:59 PM - Last Modified 08/28/24 14:21 PM


Symptom


  • When an Alert is raised and Prisma Sends the Alert Payload to your Splunk Integration and you see that it has Incomplete or Broken logs


Environment




Cause


  • Once an Alert is raised and upon viewing the Alert Payload on your Splunk Integration as it seems incomplete or broken.
GUI > Splunk Environment
Screenshot 2023-08-30 at 7.34.06 AM.png


Resolution


  1. Please take note that by default that Splunk limits messages to 10,000 bytes (characters). You can increase this limit in the Splunk properties files depending on the size of your JSON records.
  2. Please use this link that better explains this situation and how to increase the limit.
  3. Once the limit has been increased as you should be able to see the complete Logs for future Alerts.


Additional Information


  • To test and have the same Alert ID sent to your Splunk again as you may need to re-trigger the Alert.
  • Please note that once Prisma receives the notification message from alert service that it will send the same data to Splunk by using notification template schema . As there will beno enrichment of data in notification service and size will not be more then 800kb.


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    https://knowledgebase.paloaltonetworks.com/KCSArticleDetail?id=kA14u000000XgZCCA0&lang=en_US&refURL=http%3A%2F%2Fknowledgebase.paloaltonetworks.com%2FKCSArticleDetail&refURL=http%3A%2F%2Fknowledgebase.paloaltonetworks.com%2FKCSArticleDetail

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