Prisma Cloud Compute: When upgrading defenders in GCP using auto-defend for daemonsets, there is an error "Error fetching Daemonset: multiple found"

Prisma Cloud Compute: When upgrading defenders in GCP using auto-defend for daemonsets, there is an error "Error fetching Daemonset: multiple found"

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Created On 03/07/25 00:46 AM - Last Modified 12/31/25 20:47 PM


Symptom


When upgrading defenders in GCP using auto-defend for daemonsets, error message "Error fetching Daemonset: multiple found" is displayed



Environment


  • GCP
  • Prisma Cloud Compute: v33


Cause


  • This issue occurs when more than one daemonset is deployed in the kubernetes environment for a cluster. 
  • For example, one defender daemonset may be onboarded in namespace "twistlock", and another may be deployed in namespace "twistlock2".
  • If, the error message is seen after upgrading via the auto-defend page, this is likely because the namespace was not specified in "Advanced Settings".
  • If the original defender installed on a cluster was in namespace "twistlock2" and the namespace wasn't specified,  then there will be two namespaces with defender daemonsets. (By default, the namespace defenders are deployed in is "twistlock").


Resolution


  1. Gain access to the kubernetes environment where the error is taking place.
  2. Delete all defender daemonsets in the two or more namespaces in the cluster.
  3. Redeploy the defender yaml file in the cluster so only one daemonset is present.
  4. On the next upgrade cycle, ensure that, when clicking the upgrade button in "Manage > Defenders > Defenders: Auto-defend", the correct namespace is specified in Advanced Settings.



Additional Information


If the error is due to timeout, Refer "Error fetching DaemonSet

 



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