Log collector software information is missing or not updated in Panorama GUI after upgrade

Log collector software information is missing or not updated in Panorama GUI after upgrade

1622
Created On 02/05/25 03:14 AM - Last Modified 02/05/25 04:06 AM


Symptom


  • Log collector software information is missing or not updated in Panorama GUI after upgrade (Panorama > Managed Collectors > Software version)

sw_notupdated.png

  • Logs from this log collector is also not showing up in Monitor > Logs > Traffic
  • Doing a 'show panorama-status' from the log collector will show that it is connected to panorama

pn_status.png

  • In the reportd.log of the log collector, you may see the error "Failed to get device information from db for panorama".

2025-01-28 04:46:56.013 -0500
 Error:  pan_cfg_mongo_get_device_info(src_cms/pan_cfg_mongo_tables.c:3100): pan_mongo_find_one() failed.
 Failed to get device information from db for panorama

2025-01-28 04:46:56.013 -0500 Error:  pan_cfg_mongo_get_device_info(src_cms/pan_cfg_mongo_tables.c:3100):
 pan_mongo_find_one() failed.
 Failed to get device information from db for panorama2

 



Environment


Panorama
PAN-OS



Cause


The log collector might have been wrongly configured as a firewall device.

Next Step: > Go to panorama GUI > Panorama > Managed Devices > Summary 

  • Search for the serial number of the log collector
  • If you are able to see it here then it means that the LC has been wrongly added as a firewall device and must be removed from here


Resolution


  • Remove the log collector serial number from panorama GUI > Panorama > Managed Devices > Summary
  • Commit to panorama
  • Push to Collector group

 



Additional Information


N/A

Actions
  • Print
  • Copy Link

    https://knowledgebase.paloaltonetworks.com/KCSArticleDetail?id=kA14u000000TpcRCAS&lang=en_US&refURL=http%3A%2F%2Fknowledgebase.paloaltonetworks.com%2FKCSArticleDetail