PanGPS 服务在重启后无法启动,需要手动干预。

PanGPS 服务在重启后无法启动,需要手动干预。

11062
Created On 10/07/24 12:11 PM - Last Modified 02/07/25 21:57 PM


Symptom


- 笔记本电脑重新启动后,GlobalProtect 不会自动启动。



Environment


窗户。
- 全球保护任何版本。
- 安装了 Citrix 软件。


Cause


- 检查是否安装了使用以下DLL的任何 Citrix 软件:FeatureFlagHelper64.dll
- Citrix 软件在某些进程(包括 PanGPS)中注入上述DLL ,对服务造成影响并导致服务中断,从而导致服务启动延迟。
- 生成 Windows 事件日志并检查崩溃或超时错误。


Resolution


1 - 将 PanGPS 服务从“自动启动”更改为“自动延迟启动”。
转到 Windows 服务控制 > PANGPS > 右键单击​​ > 属性 > 常规 > 自动延迟重启。

2 - 如果上述方法不能解决问题,请修改注册表并配置120 秒延迟。
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\PANGPS > 创建条目AutoStartDelay (DWORD (32bit(位-bit))) > 以毫秒为单位分配值 120000。

3 - 如果步骤 1 和 2 不能解决问题,请卸载 Citrix 或以不将DLL注入 PanGPS 的方式配置。


Additional Information


- 测试 Citrix 是否影响 PanGPS 的最快方法是卸载 Citrix 并进行测试。如果问题消失,则表示 Citrix 确实影响了 PanGPS。
- Citrix 的以下官方链接表明某些DLL被注入到某些进程中:
https://docs.citrix.com/en-us/citrix-workspace-app/app-protection.html


Actions
  • Print
  • Copy Link

    https://knowledgebase.paloaltonetworks.com/KCSArticleDetail?id=kA14u000000TpDqCAK&lang=zh_CN&refURL=http%3A%2F%2Fknowledgebase.paloaltonetworks.com%2FKCSArticleDetail&refURL=http%3A%2F%2Fknowledgebase.paloaltonetworks.com%2FKCSArticleDetail

Choose Language