El servicio PanGPS no se inicia después de reiniciar, lo que requiere intervención manual.
11246
Created On 10/07/24 12:11 PM - Last Modified 02/07/25 21:57 PM
Symptom
- Después de reiniciar la computadora portátil, GlobalProtect no se inicia automáticamente.
Environment
- Ventanas.
- Protección global de cualquier versión.
- Software Citrix instalado.
Cause
- Compruebe si hay algún software Citrix instalado que utilice la siguiente DLL: FeatureFlagHelper64.dll
- El software de Citrix inyecta la DLL anterior en algunos procesos, incluido PanGPS, lo que afecta el servicio y provoca interrupciones en el mismo, generando demoras en el inicio de los servicios.
- Genere registros de eventos de Windows y verifique errores de fallas o tiempo de espera .
Resolution
1 - Cambie el servicio PanGPS de "inicio automático" a " inicio automático retrasado ".
Vaya a Control de servicios de Windows > PANGPS > haga clic derecho > Propiedades > General > Reinicio automático retrasado.
2 - Si lo anterior no soluciona el problema, modifique el registro y configurar un retraso de 120 segundos.
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\PANGPS > Crear entrada AutoStartDelay (DWORD (32 bit)) > asignar valor en ms, 120000.
3 - Si los pasos 1 y 2 no solucionan el problema, desinstale Citrix o configurar de manera que la DLL no se inyecte en PanGPS.
Additional Information
- La forma más rápida de comprobar si Citrix está afectando a PanGPS es desinstalarlo y realizar la prueba. Si el problema desaparece, Citrix está afectando a PanGPS.
- El siguiente enlace oficial de Citrix indica que ciertas DLL se inyectan en algunos procesos:
https://docs.citrix.com/en-us/citrix-workspace-app/app-protection.html