PanGPS service does not start after a reboot, requiring manual intervention.

PanGPS service does not start after a reboot, requiring manual intervention.

15264
Created On 10/07/24 12:11 PM - Last Modified 02/07/25 21:57 PM


Symptom


After the laptop reboots, the GlobalProtect does not start automatically.



Environment


  • Windows
  • Global Protect any version
  • Citrix software installed


Cause


  • Check if there is any Citrix software installed that uses the FeatureFlagHelper64.dll. 
  • Citrix software injects above DLL in some processes, including PanGPS, impacting the service and causing disruption on it, introducing delays in initiating services.
  • Generate Windows events logs and check for crash or timeout errors.
     


Resolution


  1. Change PanGPS service from "automatic start" to "automatic delayed start".
    • Go to Windows Service Control > PANGPS > right click > properties> General > Automatic delayed restart.
  2. If the above does not fix the problem, modify the registry and configure a 120-second delay.
    • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\PANGPS > Create entry AutoStartDelay (DWORD (32-bit)) > assign value in ms, 120000.
  3. If steps 1 and 2 do not fix the issue, uninstall Citrix or work with Citrix support to not inject the DLL into PanGPS. 


Additional Information




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