Der PanGPS-Dienst startet nach einem Neustart nicht und erfordert einen manuellen Eingriff.
11272
Created On 10/07/24 12:11 PM - Last Modified 02/07/25 21:57 PM
Symptom
- Nach dem Neustart des Laptops startet GlobalProtect nicht automatisch.
Environment
- Windows.
- Globaler Schutz für alle Versionen.
– Citrix-Software installiert.
Cause
– Überprüfen Sie, ob Citrix-Software installiert ist, die die folgende DLL verwendet: FeatureFlagHelper64.dll
- Citrix-Software fügt die oben genannte DLL in einige Prozesse ein, einschließlich PanGPS, was sich auf den Dienst auswirkt und zu Störungen führt, was zu Verzögerungen beim Starten der Dienste führt.
- Erstellen Sie Windows-Ereignisprotokolle und suchen Sie nach Absturz- oder Timeout Fehlern.
Resolution
1 – Ändern Sie den PanGPS-Dienst von „automatischer Start“ in „ automatischer verzögerter Start “.
Gehen Sie zu Windows-Dienststeuerung > PANGPS > Rechtsklick > Eigenschaften > Allgemein > Automatischer verzögerter Neustart.
2 – Wenn das Problem durch die oben genannten Maßnahmen nicht behoben wird, ändern Sie die Registrierung und konfigurieren eine Verzögerung von 120 Sekunden.
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\PANGPS > Eintrag AutoStartDelay (DWORD (32- Bit (Bit))) erstellen > Wert in ms zuweisen, 120000.
3 – Wenn die Schritte 1 und 2 das Problem nicht beheben, deinstallieren Sie Citrix oder konfigurieren es so, dass die DLL nicht in PanGPS eingefügt wird.
Additional Information
- Der schnellste Weg, um zu testen, ob Citrix PanGPS beeinträchtigt, besteht darin, Citrix zu deinstallieren und zu testen. Wenn das Problem verschwindet, beeinträchtigt Citrix tatsächlich PanGPS.
– Der folgende offizielle Link von Citrix weist darauf hin, dass in einige Prozesse bestimmte DLL eingeschleust werden:
https://docs.citrix.com/en-us/citrix-workspace-app/app-protection.html