GlobalProtect App upgrade failure on Windows Devices

GlobalProtect App upgrade failure on Windows Devices

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Created On 09/19/24 03:19 AM - Last Modified 02/06/25 07:30 AM


Symptom


  • GlobalProtect (GP) App installed on Windows devices.
  • "Allow Manually" upgrade fails when the user tries to upgrade the GP App from lower version to specific versions below.
    GlobalProtect App 6.0.9 or less
    GlobalProtect App 6.1.4 or less
    GlobalProtect App 6.2.3 or less
    GlobalProtect App 6.3.0
  • The setting is configured under GUI: Network > GlobalProtect > Portals > [portal-name] > Agent > [agent-name] > App > Allow User to Upgrade GlobalProtect App > Allow Manually.


Environment


  • Prisma Access
  • GlobalProtect App on Windows


Cause


Software issue under GPC-18702.



Resolution


  1. The issue has been fixed in the newer versions.
  2. Upgrade to the following GP App versions manually will fix the issue. Software images (.msi file) can be downloaded in Customer Support Portal > Updates > Software Updates. 
    • GlobalProtect App 6.0.10
    • GlobalProtect App 6.1.5
    • GlobalProtect App 6.2.4
    • GlobalProtect App 6.3.1
       


Additional Information


  • The fix GPC-18702 will work when the fixed version is the source version of the upgrade, not the target version.
    example,
    • Upgrade from 6.2.2 to 6.2.4 :  Failure due to GPC-18702
    • Upgrade from 6.2.4 to 6.2.6 :  No failure due to GPC-18702


Actions
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    https://knowledgebase.paloaltonetworks.com/KCSArticleDetail?id=kA14u000000TpB2CAK&lang=en_US&refURL=http%3A%2F%2Fknowledgebase.paloaltonetworks.com%2FKCSArticleDetail

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