Commit to Prisma Access fails with the error "Failed to get cfg.csp-trusted-endpoint value, returning None", and some license keys in Panorama are old.
2474
Created On 05/10/24 05:13 AM - Last Modified 01/10/25 03:56 AM
Symptom
Commit to Prisma Access fails with both of the following conditions.
- The following log was recorded at the time just after the commit in plugin_cloud_services.log (\opt\plugins\var\log\pan\plugin_cloud_services.log in Tech Support File) of Panorama.
ERROR: [validation] Failed to get cfg.csp-trusted-endpoint value, returning None - When executing the Panorama CLI command "delete license key [then click tab key]" (It shows all installed license keys), some old keys are displayed.
admin@Panorama> delete license key Device_Management_License_2021_01_01_13572468.key 2024/05/05 12:12:12 0.3K LCL_MU_RN_ENT_2023_01_01.key 2024/05/05 12:12:12 0.3K Logging_Service_2023_01_01.key 2024/05/05 12:12:12 0.3K Premium_Partner_2021_01_01_12345678.key 2021/07/07 11:11:11 0.3K <<<<<<<<<<<< Premium_Partner_2022_01_01_23456789.key 2022/08/08 22:22:22 0.3K <<<<<<<<<<<< Premium_Partner_2023_01_01_34567890.key 2024/05/05 12:12:12 0.3K <value> File name
Environment
- Panorama managed Prisma Access
- Commit
- Licenses
Cause
Older expired licenses still present in the Panorama.
Resolution
- Delete all the keys and retrieve the newer keys from the license server.
- Follow steps from STEP1 to STEP8 of Reset Your Panorama Managed Prisma Access License.