Error: "Invalid content image, Failed to download file" seen during PAN-OS Software download

Error: "Invalid content image, Failed to download file" seen during PAN-OS Software download

1414
Created On 03/13/25 14:12 PM - Last Modified 09/19/25 03:37 AM


Symptom


  • When downloading PAN-OS software, the job fails with error "Invalid content image, Failed to download file."
  • Configd.log (less mp-log configd.log) contains error "download invalid object size (0)"
  • The image does not show as downloaded in the GUI and the "Download" button still appears
  • When executing "request system software info" from the CLI, the software version is seen with size "0"


Environment


  • Palo Alto Networks Firewall or Panorama
  • Supported PAN-OS


Cause


The software package is corrupt and has to be manually deleted and re-downloaded.



Resolution


Execute the commands below from the CLI, as the image does not appear in the GUI:

  1. Delete the corrupt software image:
    • > delete software version {version}
  2. Run a software check to get a fresh list of software images
    • > request system software check
  3. Download the fresh version of the software
    • > request system software download version {version} 

 

If the download still fails, consider temporarily disabling the "Verify Update Server Identity" option and perform the download.

  • In GUI "Verify Update Server Identity" can be found under
    • Device > Setup > Services
  • From the CLI execute the commands below: 
    > configure
    # set deviceconfig system server-verification no
    # commit


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