GlobalProtect Embedded Browser opens but page displayed is blank (SAML)
Symptom
The GlobalProtect embedded browser opens but is blank, no web content is displayed intermittently. Refreshing the connection or changing the size of the browser window allows the content to show.
Environment
- Prisma Access Mobile Users or NGFW On-Premise GW
- GlobalProtect Versions Equal to or below (6.2.7, 6.3.2, 6.1.5, 6.0.12)
- SAML authentication
- Embedded browser
- Windows 11
Cause
A set of recent Microsoft updates (KB5051987/KB5051989) has impacted the embedded browsers ability to reliably display the web content.
Resolution
Fix for this issue is out now for 6.2.x release with version 6.2.8
Fixes for other versions are in 6.0.13, 6.1.6, 6.3.3. (not released as of April 16 2025)
Check for GPC-22542 in the GlobalProtect release notes for each version to validate the fix included once they are out.
Current Known Workarounds:
- Remove the MS update from impacted machines
If permissions allow, users can uninstall the updates by navigating to: Settings > Windows Update > Update History > Uninstall Updates
2. Resize or maximize the embedded browser
Have the user manually maximize the page, or resize the page. This will allow the content to properly display, please see a video sample below.