DLP plugin error during commit Unable to connect to API gateway. (28, 'Resolving timed out after 30000 milliseconds')
Symptom
- Commit fails with error "Unable to connect to API gateway. (28, 'Resolving timed out after 30000 milliseconds')"
Profile Bulk CCN error: Unable to connect to API gateway. (28, 'Resolving timed out after 30000 milliseconds')
push_dlp_config_to_cloud failed
Failed plugin validation
- DNS resolution fails indicating connectivity issues. In this example it displays "System error"
Panorama> ping host api.gpcloudservice.com
ping: api.gpcloudservice.com: System error
Panorama> ping host hawkeye.services-edge.paloaltonetworks.com
ping: hawkeye.services-edge.paloaltonetworks.com: System error
Environment
- Panorama
- DLP plugin installed
Cause
DNS or connectivity to api.gpcloudservice.com, hawkeye.services-edge.paloaltonetworks.com is not working.
Resolution
- Ensure the DNS services and the connectivity to the FQDNs work correctly. Modify the traffic policy if necessary .
- Refer to the PreRequesites for Enterprise DLP.
- If the issue still persists, Reset the DLP plugin config on Panorama CLI, followed by a commit to resolve the error/issue:
Panorama> request plugin dlp reset
Panorama> configure
# commit
- It can take some time for dlp plugin to synchronize with Palo Alto Networks Cloud.
- If the issue is still not resolved, open a support case.
Additional Information
Note: DLP plugin logs are too confirm the commit-validate errors
|
2025-02-18 06:53:13.391 -0500 INFO: [commit-validate] Profile type predefined, name Bulk CCN send to enforcer 2025-02-18 06:53:13.394 -0500 INFO: [commit-validate] Accessing DLP URL : https://enforcer-hawkeye.services-edge.paloaltonetworks.com:443/v2/dlp/plugin-data-profile/1234235346 |